Serum not showing up in Logic Pro X??

Started by oliwing


I have Logic Pro X 10.4 and just bought and installed Serum. After uninstalling and reinstalling multiple times (each time it says it has successfully installed) the plugin isn't showing up in Logic. I have checked in the Library/Audio/Plug-ins/Components folder and there isn't a Serum component there. If anyone knows whats going on I'd be grateful of any help cos slightly worried I've just wasted £137 on something that doesn't work :/


Hi Oliwing,

I think I answered your email already, restart the computer and it will appear.

Warm regards,

That solved it for me too. Should be written while installation somewhere, because waste of time until found the solution here.


your OS is newer than the installation, I'm working on resolving that!


I'm having the same issue as other customers, is restarted my Mac and serum still isn't chowing up in Logic Pro x. Is there something else I need to do with the PKG file?


I'm having the same issue as other customers, I restarted my Mac and serum still isn't showing up in Logic Pro x. Is there something else I need to do with the PKG file?


You might need to clear your AU cache.

command-shift-G in Finder (go to folder)
(including the ~ mark)

delete the "" file located in the above folder.
delete the AudioUnitCache folder located in the above folder.

I would recommend to log out (or restart) the computer after deleting the above (not certain it is needed, but can't hurt).

Also make sure you are looking on a Software Instrument insert, and not an effect insert.

Hope this helps,



None of the above suggestions are working for me.

  1. I have my own updated copy of Logic Pro X
  2. I have a software instrument insert chosen.
  3. Serum previously worked fine with High Sierra.
    I just installed the latest- Mojave -for Macbook.
    Please update and anticipate for all OS makers and compatable machines.
    The affordability of the subscription plan is much appreciated but it means that your reach will find a home on less-than-expensive-machines.

Thank you.



P.S. No such "" folder when following your directions.


Do you see Serum in Logic->Preferences->Plugin Manager ?
Have you restarted the machine since installing Serum?

If the problem persists go to Applications/Utilities/ and
paste this line of text:
auval -v aumu XfsX XFER

and paste the result here, or email result to


Steve, I'm sorry. I found Serum in Logic Pro X after contacting Delando in Splice live chat support. As I said I used Serum before with High Sierra. I forgot that Serum was located at the bottom of LPXs software instruments list under 'AU Instruments'. After saving/naming a project Serum. I can have Serum at the top of that software instrument list. Back on the road again. Sorry about my panic. Sincerely, Jpeek345


Good to hear, you mentioned software instrument insert or I would have mentioned that.

Micah Ray

I own an iMac made in 2009 that runs on macOS High Sierra. I tried downloading Serum and after trying for 3 hours, Logic still has not recognized Serum as a plug-in. I have done everything said in this specific topic, and I tried installing Splice since I heard that splice would automatically sort everything out and redirect Serum to where it needs to go, however, Splice is also not installing and I'm currently in the process of getting help from their team as well. My guess is that for some reason my computer isn't downloading the vst for Serum since I haven't been able to locate it anywhere on my computer. It appears to be replaced by aax files but at this point, I don't know what I should be looking for.


Logic doesn't use VST, it uses components (AU).
RESTART THE COMPUTER < important on High Sierra
Launch Logic -> Logic Menu -> Preferences -> Plugin Manager
see if Serum is in the list there. If it is and enabled it should be on an instrument insert (not effect insert).

If not tell me what the AUVAL result is as mentioned in an above post:
go to Applications/Utilities/ and
paste this line of text:
auval -v aumu XfsX XFER

Micah Ray

Oh god I am so sorry I actually downloaded the windows version for some reason! I have absolutely NO idea why but I guess for some reason I switched the two up in my head. I am so sorry for wasting your time!!!


Hey Steve, just signed up for Serum, it is showing up under logic / preferences / audio unit managers. But when I click new track I don't see an option to choose serum. I am using Mac Mojave with logic pro x 10.0.0


You need to look on an instrument insert, not an effects insert.


oh, thx i had the same problem